Trip Report Editing Issue

Check here for updates to the forum and site.
Forum rules
  • This is a mountaineering forum, so please keep your posts on-topic. Posts do not all have to be related to the 14ers but should at least be mountaineering-related.
  • Personal attacks and confrontational behavior will result in removal from the forum at the discretion of the administrators.
  • Do not use this forum to advertise, sell photos or other products or promote a commercial website.
  • Troll posts will be removed.
For more details, please see the Terms of Use you agreed to when joining the forum.
User avatar
Wentzl
Posts: 932
Joined: 7/29/2008
14ers: 58 22
13ers: 54
Trip Reports (48)

Re: Trip Report Editing Issue

Post by Wentzl »

I think that time is an element in the glitch. I tried to duplicate my experience this morning, hacking out a fake report. But everything worked just like it should.

The times I lost a report, I was at the computer over 2 hours.

Funny thing, now I am unable to correctly duplicate the captcha code and unable to delete the report!
Shorter of Breath and One Day Closer . . .

https://www.youtube.com/watch?v=YZXKgl8turY
User avatar
daway8
Posts: 937
Joined: 8/24/2017
14ers: 58 21
13ers: 129 25
Trip Reports (59)

Re: Trip Report Editing Issue

Post by daway8 »

This sounds like perhaps the same issue I reported previously (see https://14ers.com/forum/viewtopic.php?f=9&t=57723 )

The solution then was to hit the "Save as inactive" periodically while writing the report.

Bill later added a recovery feature that spit out the html code for everything that had been in the report and allowed you to copy/paste to restore what had just been lost. I tried that successfully a while after that but ever since have just made sure to regularly hit "save as inactive" then come back in and continue editing and I've never had that problem since.
User avatar
yaktoleft13
Posts: 376
Joined: 4/17/2017
14ers: 58 10
13ers: 188 9
Trip Reports (15)

Re: Trip Report Editing Issue

Post by yaktoleft13 »

daway8 wrote: Tue Jul 27, 2021 1:19 pm This sounds like perhaps the same issue I reported previously (see https://14ers.com/forum/viewtopic.php?f=9&t=57723 )

The solution then was to hit the "Save as inactive" periodically while writing the report.

Bill later added a recovery feature that spit out the html code for everything that had been in the report and allowed you to copy/paste to restore what had just been lost. I tried that successfully a while after that but ever since have just made sure to regularly hit "save as inactive" then come back in and continue editing and I've never had that problem since.
The last report I wrote I saved as inactive periodically throughout the drafting process. One of those times, it didn't save and lost the 4 or 5 paragraphs I'd most recently written and defaulted back to the save before. At least I didn't lose the whole thing, but the save as inactive feature is subject to the same glitch
User avatar
CaptainSuburbia
Posts: 949
Joined: 10/7/2017
14ers: 58 34
13ers: 120 18
Trip Reports (40)

Re: Trip Report Editing Issue

Post by CaptainSuburbia »

Hitting the save as inactive feature is what cause the glitch for me.
Some day our kids will study Clash lyrics in school.
Nothing drives people crazy like people drive people crazy.
Save Challenger Point
User avatar
supranihilest
Posts: 554
Joined: 6/29/2015
14ers: 58 35
13ers: 629 17
Trip Reports (102)
Contact:

Re: Trip Report Editing Issue

Post by supranihilest »

daway8 wrote: Tue Jul 27, 2021 1:19 pm This sounds like perhaps the same issue I reported previously (see https://14ers.com/forum/viewtopic.php?f=9&t=57723 )

The solution then was to hit the "Save as inactive" periodically while writing the report.

Bill later added a recovery feature that spit out the html code for everything that had been in the report and allowed you to copy/paste to restore what had just been lost. I tried that successfully a while after that but ever since have just made sure to regularly hit "save as inactive" then come back in and continue editing and I've never had that problem since.
The thing that shows you the TR source code upon saving or upon some error is different. I've only seen that like two times and have no idea what triggered it, but it's clearly a solution Bill implemented to fix a known and different issue. What everyone else is talking about is something else and isn't caught by the same process, hence the data loss.
User avatar
BillMiddlebrook
Site Administrator
Posts: 6606
Joined: 7/25/2004
14ers: 58 46 22
13ers: 168 58 45
Trip Reports (7)
Contact:

Re: Trip Report Editing Issue

Post by BillMiddlebrook »

Until I can look into it more and replicate the problem, I just added some debugging stuff to save raw trip text in a database every time one of the save buttons is tapped. Specifically, the report text as it was on the screen and then after it has been prepped and saved to the trip report. Maybe next time it happens I can determine the location and apply a fix.
“Today, up on this hill
I'm counting all the killers
They sway as they swarm
A look of gluttons in their eyes
They mutter as the body loses warmth
They pick your bones like locks inside a tomb
And take great care to not take care of you”
User avatar
BillMiddlebrook
Site Administrator
Posts: 6606
Joined: 7/25/2004
14ers: 58 46 22
13ers: 168 58 45
Trip Reports (7)
Contact:

Re: Trip Report Editing Issue

Post by BillMiddlebrook »

UPDATE: 8/4/2021

I did some debugging and monkeying around with this thing and still can't replicate the problem myself. I'm pretty sure it has something to do with the browser session process while the user is working on the report.

SO...

I have rewritten the "Save" interface to save data on-the-fly, without submitting the page. When editing a report, you will notice two major differences: 1) A single Save button instead of two (inactive and activate) and 2) the Inactive/Active status is specified on the "Main" edit tab. When "Save" is clicked, data is validated and saved to the database and a success or failure message will be displayed. I hope this will fix the problem.

Please post in this thread if you have any further problems with the edit page. Sorry for the hassle and thanks for your patience!
“Today, up on this hill
I'm counting all the killers
They sway as they swarm
A look of gluttons in their eyes
They mutter as the body loses warmth
They pick your bones like locks inside a tomb
And take great care to not take care of you”
User avatar
CaptainSuburbia
Posts: 949
Joined: 10/7/2017
14ers: 58 34
13ers: 120 18
Trip Reports (40)

Re: Trip Report Editing Issue

Post by CaptainSuburbia »

Thanks Bill!

I'm having a new issue when editing from mobile. Only half the page is fitting on the screen and there's no way to scroll to the rest.
20210808_112932.jpg
20210808_112932.jpg (72.93 KiB) Viewed 4872 times
Some day our kids will study Clash lyrics in school.
Nothing drives people crazy like people drive people crazy.
Save Challenger Point
User avatar
BillMiddlebrook
Site Administrator
Posts: 6606
Joined: 7/25/2004
14ers: 58 46 22
13ers: 168 58 45
Trip Reports (7)
Contact:

Re: Trip Report Editing Issue

Post by BillMiddlebrook »

I moved to the latest version of the TinyMCE editor (3rd party) and they must have made a change, causing the editor area not to wrap on small screens. I just switched it back to their previous version so it should be ok once you refresh.

I'm headed out to a climb tomorrow and will be sure to fix that when I return.

Thanks for the help!
“Today, up on this hill
I'm counting all the killers
They sway as they swarm
A look of gluttons in their eyes
They mutter as the body loses warmth
They pick your bones like locks inside a tomb
And take great care to not take care of you”
User avatar
CaptainSuburbia
Posts: 949
Joined: 10/7/2017
14ers: 58 34
13ers: 120 18
Trip Reports (40)

Re: Trip Report Editing Issue

Post by CaptainSuburbia »

BillMiddlebrook wrote: Sun Aug 08, 2021 12:43 pm I moved to the latest version of the TinyMCE editor (3rd party) and they must have made a change, causing the editor area not to wrap on small screens. I just switched it back to their previous version so it should be ok once you refresh.

I'm headed out to a climb tomorrow and will be sure to fix that when I return.

Thanks for the help!
That worked. Thanks!
Some day our kids will study Clash lyrics in school.
Nothing drives people crazy like people drive people crazy.
Save Challenger Point
User avatar
BillMiddlebrook
Site Administrator
Posts: 6606
Joined: 7/25/2004
14ers: 58 46 22
13ers: 168 58 45
Trip Reports (7)
Contact:

Re: Trip Report Editing Issue

Post by BillMiddlebrook »

CaptainSuburbia wrote: Sun Aug 08, 2021 1:19 pm
BillMiddlebrook wrote: Sun Aug 08, 2021 12:43 pm I moved to the latest version of the TinyMCE editor (3rd party) and they must have made a change, causing the editor area not to wrap on small screens. I just switched it back to their previous version so it should be ok once you refresh.

I'm headed out to a climb tomorrow and will be sure to fix that when I return.

Thanks for the help!
That worked. Thanks!
I spent some time this morning getting the new TinyMCE version (the TR editing interface) to format properly on mobile and I think I have it. Let me know if you have any problems with it.
Thanks
“Today, up on this hill
I'm counting all the killers
They sway as they swarm
A look of gluttons in their eyes
They mutter as the body loses warmth
They pick your bones like locks inside a tomb
And take great care to not take care of you”
arianna2
Posts: 124
Joined: 8/23/2009
14ers: 58
13ers: 9
Trip Reports (45)

Re: Trip Report Editing Issue

Post by arianna2 »

I notice that the text and the pictures are on the same scroll bar now. The photos stay at the top so once you have a longer report you can't see your photos and grabbing one and bringing it down is hard-you have to hold the photo and scroll down with it. Any other options on this?
Post Reply